Cómo devolver COLUMNAS DINÁMICAS en Excel usando BUSCARV y BUSCARX

Este video es la onda!

Te voy a enseñar 4 trucos que tal vez no conocías para devolver columnas dinámicas en Excel usando BUSCARV y BUSCARX. Lo haremos usando rangos normales y Tablas.

Ver video Columnas dinámicas con BUSCARV y BUSCARX

Suscríbete al canal de EXCELeINFO en YouTube para aprender más de Excel y macros.

Columnas dinámicas con BUSCARV aplicado a rangos

Para usar columnas dinámicas con BUSCARV, debemos combinar la función con COINCIDIR, para buscar el nombre del encabezado y usar el número devuelto como parámetro de columna.

BUSCARV y COINCIDIR en Excel

Figura 1. BUSCARV y COINCIDIR en Excel.

Fórmula:

=BUSCARV(C4,A9:F14,COINCIDIR(C5,A9:F9,0),0)

Columnas dinámicas con BUSCARX aplicado a rangos

A diferencia de BUSCARV, donde tenemos que indicar el número de la columna a devolver, con BUSCARX debemos indicar el rango a devolver, por lo que COINCIDIR no nos sirve para este caso.

Si no sabías, BUSCARX también puede devolver rangos, por lo que si anidamos un BUSCARX dentro de otro, vamos a poder devolver el valor de una columna de manera dinámica.

Figura 2. Anidar BUSCARX para devolver una valor de cualquier columna de manera dinámica

Figura 2. Anidar BUSCARX para devolver una valor de cualquier columna de manera dinámica.

Fórmula:

=BUSCARX(C4,A9:A14,BUSCARX(C5,B9:F9,B9:F14))

Columnas dinámicas con BUSCARV aplicado a Tablas

La ventaja de usar Tablas, es que el tamaño de los rangos es dinámico y trabajamos a nivel columna, no a nivel rango.

Pero cuando queremos aplicar BUSCARV o BUSCARX con Tablas, debemos aplicar las funciones un tanto diferentes a como lo haríamos con rangos.

Usamos COINCIDIR para devolver la columna, pero aplicaremos un truco. Los encabezados de las tablas son considerados como texto, aunque el valor sea numérico. Es por esto que debemos usar la función TEXTO para cambiarle el formato al año que tenemos en la celda C5.

BUSCARV en Tablas devolviendo la columna de manera dinámica

Figura 3. BUSCARV en Tablas devolviendo la columna de manera dinámica.

Fórmula:

=BUSCARV(C4,Tabla3[#Todo],COINCIDIR(TEXTO(C5,”0″),Tabla3[#Encabezados],0),0)

Columnas dinámicas con BUSCARX aplicado a Tablas

Esto se pone más interesante.

Así como aplicar BUSCARX en rangos se vuelve tarea interesante, aplicarlo en Tablas, requiere de más imaginación. Aquí haremos uso de la función INDIRECTO.

La función INDIRECTO nos ayuda a hacer referencia a un rango con nombre y devolver sus valores. En este caso, haremos referencia a los encabezados de la Tabla.

Aplicar INDIRECTO para devolver una columna dinámicamente con BUSCARX en Tablas

Figura 4. Aplicar INDIRECTO para devolver una columna dinámicamente con BUSCARX en Tablas.

Fórmula:

=BUSCARX(F4,Tabla3[DEPARTAMENTO],INDIRECTO(“Tabla3[“&F5&”]”,VERDADERO))

Descarga el archivo para practicar

Columnas dinámicas con BUSCARV y BUSCARX – EXCELeINFO.zip

Si te gustó este tutorial, por favor regístrate en nuestra Lista de correo y Suscríbete a nuestro canal de YouTube para que estés siempre enterado de lo nuevo que publicamos.

You may also like...

Leave a Reply

Your email address will not be published.

%d bloggers like this: