Cuál es mejor? BUSCARV vs ÍNDICE Y COINCIDIR vs BUSCARX

Ha llegado el momento de la pelea de siglo en Excel, una batalla épica entre funciones de Excel. Durante años, la función BUSCARV ha sido la reina de las funciones de búsqueda. De hecho, yo la uso todos los días porque me soluciona todas las situaciones. Sí, TODAS.

Por otro lago, hay personas que recomiendas no usarla, sino quedarse la combinación de funciones ÍNDICE y COINCIDIR, aunque la curva de aprendizaje sea más larga, pero fructífera. Ahora bien, en el año 2019 llega la joya de la corona de Microsoft Excel, la función BUSCARX, la cual nos ofrece mucha flexibilidad a la hora de hacer búsquedas en Excel, sin embargo, no todo es miel sobre hojuelas.

¿Con cuál te quedas?

Ver Video BUSCARV vs ÍNDICE Y COINCIDIR vs BUSCARX

Suscríbete al canal de EXCELeINFO en YouTube para aprender más de Excel y macros.

ROUND 1. BUSCARV

La función BUSCARV nos permite encontrar valores basados en un valor de una columna de la derecha. Al encontrar un valor, se devolverá otro valor de la misma y en la columna especificada en el parámetro indicador-columna.

Beneficios

  • Encontrar valores hacia la derecha de una tabla.
  • Podemos usar comodines.
  • Búsquedas exactas y aproximadas.
  • Fácil de dominar.

Sintaxis BUSCARV

=BUSCARV(valor_buscado, matriz_tabla, indicador_columnas, [rango])

Parámetros

  • valor_buscado. Es el valor que se buscará en la primer columna de la tabla.
  • matriz_tabla. El rango o tabla donde haremos la búsqueda.
  • indicador_columnas. La columna donde está el valor que devolveremos.
  • rango. Opcional. FALSO para búsqueda exacta y VERDADERO para búsqueda aproximada (binaria).

Ejemplo de BUSCARV

Deseamos obtener el promedio de ventas de un vendedor. Usaremos la siguiente fórmula:

=BUSCARV(G4,B4:E13,4,0)

Función BUSCARV en Excel

Figura 1. Función BUSCARV en Excel.

ROUND 2. ÍNDICE Y COINCIDIR

Aquí tenemos dos funciones: ÍNDICE y COINCIDIR. Por sí solas no tienen mucha utilidad, pero combinadas se vuelven potentes. Vamos a explicarlas primero por separado y luego veremos un ejemplo donde estén combinadas.

Sintaxis ÍNDICE

La función ÍNDICE nos devuelve un valor o una referencia en la intersección de una fila con una columna.

=INDICE(matriz, núm_fila, [núm_columna])

Parámetros ÍNDICE

  • matriz. En el rango de celdas.
  • núm_fila. Es la fila de donde se devolverá el valor.
  • núm_columa. Opcional. Es la columna de donde se devolverá el valor.

Ejemplo ÍNDICE

En el siguiente ejemplo deseamos devolver el nivel Master de un empleado, definiendo manualmente la fila y la columna. Usaremos la siguiente fórmula:

=INDICE(B4:C13,9,2)

Función ÍNDICE o INDEX en Excel

Figura 2. Función ÍNDICE o INDEX en Excel.

Sintaxis COINCIDIR

La función COINCIDIR nos devuelve la posición de un valor en una matriz o rango.

=COINCIDIR(valor_buscado, matriz_buscada, [tipo_de_coincidencia])

Parámetros de COINCIDIR

  • valor_buscado. Es el valor que se buscará.
  • matriz_buscada. La matriz o rango donde se buscará el valor.
  • tipo_de_coincidencia. Opcional. Es un número que índica el tipo de búsqueda. 0 para exacta.

Ejemplo COINCIDIR

En este ejemplo deseamos encontrar la posición en un rango del valor del Empleado. Recordemos que podemos hacer la búsqueda tanto en rangos verticales como horizontales.

=COINCIDIR(G3,B4:B13,0)

Función COINCIDIR en Excel

Figura 3. Función COINCIDIR en Excel.

ÍNDICE Y COINCIDIR

La combinación de estas dos celdas es poderosa, ya que podemos hacer búsquedas de valores tanto a la izquierda como a la derecha, además de poder hacer búsqueda dinámicas definiendo la columna de búsqueda en una lista de validación.

En este ejemplo buscamos el ID del empleado. Nota que el ID se encuentra a la izquierda del nombre de los empleados. Usamos la siguiente fórmula:

=INDICE(B4:B13,COINCIDIR(I3,C4:C13,0))

Funciones ÍNDICE y COINCIDIR

Figura 4. Funciones ÍNDICE y COINCIDIR.

Ahora en este ejemplo haremos la búsqueda de los empleados, pero ahora la columna la tendremos dinámica, la cual se podrá elegir de una lista de validación.

Funciones INDEX MATCH en Excel

Figura 5. Funciones INDEX MATCH en Excel.

ROUND 3. Función BUSCARX

La función BUSCARX viene a ser una versión súper mejorada de la ya famosa función BUSCARV, aunque dudo que la reemplace, sino se agregue a la lista ya de por sí extensa de funciones en Excel.

Sintaxis BUSCARX

  • Valor_buscado. El valor a buscar.
  • Matriz_buscada. La matriz o rango donde se buscará.
  • Devolver_matriz. La matriz o rango que se devolverá.
  • Modo_de_coincidencia. Opcional. Especifica el modo de coincidencia: 0: Coincidencia exacta. Si no se encuentra ninguna, devuelve #N/A. Este valor es el predeterminado. -1: Coincidencia exacta. Si no se encuentra ninguna, devolverá el siguiente elemento más pequeño. 1: Coincidencia exacta. Si no se encuentra ninguna, devolverá el elemento más grande. 2: Una coincidencia de comodín cuando *,? y ~ tiene un significado especial.
  • Modo_de_búsqueda. Opcional. Especifica el modo de búsqueda que se usará: 1: Realiza una búsqueda comenzando por el primer elemento. Este valor es el predeterminado. -1: Realiza una búsqueda inversa a partir del último elemento. 2: Realiza una búsqueda binaria que depende de la ordenación en orden ascendente. Si no está ordenado, se devolverán resultados no válidos. -2: Realiza una búsqueda binaria que depente de la ordenación en orden descendente. Si no está ordenado, se devolverán resultados no válidos.

En el ejemplo de BUSCARX buscaremos el nivel de un empleado. Veamos que sólo debemos elegir la columna donde está el valor y la columna del valor que se devolverá, además de otros parámetros muy interesantes y curiosos.

=BUSCARX(I4,C5:C14,D5:D14,”No existe”,0,1)

Función BUSCARX en Excel

Figura 6. Función BUSCARX en Excel.

Búsqueda dinámica. Elegir la columna a devolver

Ahora te muestro la fórmula donde combinamos BUSCAX con ELEGIR y COINCIDIR para que puedas buscar valores en cualquier columna. La columna la podrás elegir de una lista de validación de datos.

=BUSCARX(I7,C5:C14,ELEGIR(COINCIDIR(H8,B4:F4,0),B5:B14,C5:C14,D5:D14,E5:E14,F5:F14),”No existe”,0,1)

Función BUSCARX en Excel junto con ELEGIR y COINCIDIR

Figura 7. Función BUSCARX en Excel junto con ELEGIR y COINCIDIR.

Te puede interesar:

Descarga el archivo de ejemplo

BUSCARV vs INDICE Y COINCIDIR vs BUSCARX.zip

Si te gustó este tutorial por favor regístrate en nuestra Lista de correo y Suscríbete a nuestro canal de YouTube para que estés siempre enterado de lo nuevo que publicamos.

You may also like...

Leave a Reply

Your email address will not be published.

%d bloggers like this: