Nueva función BUSCARX o XLOOKUP en Excel – Qué pasará con BUSCARV

Microsoft ha liberado para algunos usuarios registrados en el Programa de Office Insider la función BUSCARX o XLOOKUP en inglés. Dicha función viene a ser una versión súper mejorada de la ya famosa función BUSCARV, aunque dudo que la reemplace, sino se agregue a la lista ya de por sí extensa de funciones en Excel.

Ver video Función BUSCARX o XLOOKUP

Suscríbete al canal de EXCELeINFO en YouTube para aprender más de Excel y macros.

Ventajas de BUSCARX

Es importante considerar que esta función está en fase de pruebas, pero es completamente funcional. A continuación algunas ventajas que traerá.

  • A diferencia de BUSCARV, aquí solo debemos elegir dos columnas, lo cual hace que la función tenga mejor desempeño.
  • Es posible encontrar el último resultado.
  • La coincidencia por defecto es EXACTA, a diferencia que con BUSCARV que debíamos definirle FALSO o VERDADERO.
  • Podemos usar comodines para búsqueda aproximada.
  • BUSCARX ya viene con la mejora de desempeño que tuvo BUSCARV en el 2018.
  • Por fin nos olvidamos de definir las columnas por número, incluso si movemos las columnas o insertamos nuevas, la búsqueda seguirá funcionando.

A CONSIDERAR

  • BUSCARX comienza su despliegue el 28-ago-2019 a un cierto número de usuarios registrados en Office Insider.
  • Posteriormente se añadirá a la versión Office 365 y a todos los Insiders.

Sintaxis

A continuación enumeramos los parámetros de la función BUSARX.

ARGUMENTO

DESCRIPCIÓN

Valor_buscado

El valor a buscar.

Matriz_buscada

La matriz o rango donde se buscará.

Devolver_matriz

La matriz o rango que se devolverá.

Modo_de_coincidencia. Opcional

Especifica el modo de coincidencia:
0: Coincidencia exacta. Si no se encuentra ninguna, devuelve #N/A. Este valor es el predeterminado.
-1: Coincidencia exacta. Si no se encuentra ninguna, devolverá el siguiente elemento más pequeño.
1: Coincidencia exacta. Si no se encuentra ninguna, devolverá el elemento más grande.
2: Una coincidencia de comodín cuando *,? y ~ tiene un significado especial.

Modo_de_búsqueda. Opcional

Especifica el modo de búsqueda que se usará:
1: Realiza una búsqueda comenzando por el primer elemento. Este valor es el predeterminado.
-1: Realiza una búsqueda inversa a partir del último elemento.
2: Realiza una búsqueda binaria que depende de la ordenación en orden ascendente. Si no está ordenado, se devolverán resultados no válidos.
-2: Realiza una búsqueda binaria que depente de la ordenación en orden descendente. Si no está ordenado, se devolverán resultados no válidos.

Búsqueda sencilla

En este ejemplo buscamos el código 1012 dentro del rango A8:A75 y devolvemos un valor de la columna G. Notemos cómo no es necesario elegir toda la tabla, sino solo las columnas necesarias.

=BUSCARX(A5,A8:A75,G8:G75)

Búsqueda sencilla con BUSCARV – VLOOKUP.

Figura 1. Búsqueda sencilla con BUSCARV – VLOOKUP.

Búsqueda de matrices dinámicas

En este ejemplo, la matriz devuelta constará de dos columnas, las cuales serán de tipo matriz dinámica.

=BUSCARX(A5,A8:A75,C8:E75)

Búsqueda de tipo matrices dinámicas con BUSCARX – VLOOKUP.

Figura 2. Búsqueda de tipo matrices dinámicas con BUSCARX – VLOOKUP.

Búsqueda con comodines.

=BUSCARX(B4,B8:B75,D8:D75,2,-1)

En esta búsqueda usaremos el símbolo del asterisco como comodín, además de usar el parámetro modo_de_coincidencia con el valor 2 para indicar que es una búsqueda con comodines. En caso de que deseemos hacer una búsqueda desde el primer valor usamos el 1, pero si deseamos buscar desde el último valor usamos -1.

Búsqueda por comodines usando BUSCARX – XLOOKUP.

Figura 3. Búsqueda por comodines usando BUSCARX – XLOOKUP.

Búsqueda hacia la izquierda y con coincidencia aproximada

En este ejemplo hacemos una búsqueda hacia la izquierda. La matriz buscada es la columna B y la matriz a devolver es la de la izquierda, la columna A. Además en modo_de_coincidencia usaremos el parámetro 1, que significa coincidencia exacta o el siguiente elemento mayor.

=BUSCARX(D4,B4:B9,A4:A9,1)

Búsqueda hacia la izquierda y con búsqueda aproximada usando BUSCARX – VLOOKUP.

Figura 4. Búsqueda hacia la izquierda y con búsqueda aproximada usando BUSCARX – VLOOKUP.

Descarga el archivo de ejemplo

BUSCARX – XLOOKUP.zip

Si te gustó este tutorial por favor regístrate en nuestra Lista de correo y Suscríbete a nuestro canal de YouTube para que estés siempre enterado de lo nuevo que publicamos.

You may also like...

Leave a Reply

Your email address will not be published.

%d bloggers like this: