Combinar doble signo negativo y BUSCARV en Excel

El doble signo negativo en fórmulas de Excel nos sirve para forzar valores booleanos a valores numéricos, es decir, para covertir VERDADERO en 1 y FALSO en 0.

Para la fórmula =(A1<10) el resultado que Excel devolverá será VERDADERO o FALSO, según el valor de A1. Ahora, si deseamos forzar el valor booleano a 1 ó 0, podemos usar 3 técnicas:

    1. Usar doble signo negativo: =—(A1<10)
    2. Multiplicar por uno: =(A1<10)*1
    3. Sumar cero: =(A1<10)+0

Ver video Combinar doble signo negativo con BUSCARV en Excel

Doble signo negativo y BUSCARV

En ocasiones tengo que trabajar con números almacenados como texto o reportes extraídos desde alguna Web y me los trae, generalmente en formato texto.

Les pongo algunos ejemplos en los que he usando el doble signo negativo.

Ejemplo

En este ejemplo usaremos la función DERECHA para extraer 10 números de derecha a izquierda de una celda. Esos 10 número serán el argumento valor_buscado de la función BUSCARV.

Nota: Usaremos doble signo negativo para convertir los 10 números extraídos a formato de número.

[B2]: =BUSCARV(–DERECHA(A2,10),$E$2:$F$17,2,0)

image

Figura 1. Uso de doble signo negativo en BUSCARV.

You may also like...

Leave a Reply

Your email address will not be published.

%d bloggers like this: