Búsqueda de Imágenes usando BUSCARX e ÍNDICE y COINCIDIR en Excel

Una de las cosas que más hacemos en Excel es, usar funciones de búsqueda como BUSCARV, BUSCARX o las famosas ÍNDICE y COINCIDIR.

El uso regular de estar funciones es devolver valores de una Tabla o rango, ya sea, buscando hacia la derecha o hacia la izquierda.

En este video tutorial te enseñaré paso a paso, cómo puedes hacer búsquedas con imágenes. Elegir un valor de una lista y luego devuelves la imagen. ¿Lo conocías?

Ver video Búsqueda de imágenes

Suscríbete al canal de EXCELeINFO en YouTube para aprender más de Excel y macros.

Introducción

Búsqueda de imágenes usando BUSCARX e ÍNDICE y COINCIDIR - exceleinfo
Figura 1. Búsqueda de imágenes usando BUSCARX e ÍNDICE y COINCIDIR – exceleinfo

Usaremos 3 de las funciones de búsqueda más usadas en Excel, BUSCARX, ÍNDICE y COINCIDIR, para lograr que, al seleccionar un texto, en este caso, el nombre de un país, se devuelva la imagen de dicho país.

No usamos BUSCARV, porque no permitió hacer el procedimiento, pero también se puede usar INDIRECTO.

Usar funciones de búsqueda en Excel para devolver imágenes

Para lograr devolver una imagen usando BUSCARX o ÍNDICE y COINCIDIR, debemos asignar una fórmula a un nombre definido.

Primero definimos cuáles serán las fórmulas a usar:

BUSCARX: =BUSCARX($F$4,$B$3:$B$35,$C$3:$C$35)
ÍNDICE Y COINCIDIR: =INDICE($B$3:$C$35,COINCIDIR($F$5,$B$3:$B$35,0),2)
Crear un nombre definido en Excel - exceleinfo
Figura 2. Crear un nombre definido en Excel – exceleinfo

Una vez que tenemos las fórmulas, creamos los nombres definidos.

  • Copiamos las fórmulas.
  • Nos vamos a la ficha Fórmulas > Administrador de nombres.
  • Presionamos el botón Nuevo. Asignamos un nombre e ingresamos la fórmula.

Por último, copiamos y pegamos una imagen a la derecha de donde ingresamos el nombre del país.

Asignamos el nombre definido a la imagen - exceleinfo
Figura 3. Asignamos el nombre definido a la imagen – exceleinfo

Elegimos la imagen e ingresamos en la barra de fórmulas

=Bandera1

Descarga el archivo para practicar

Búsqueda de imágenes BUSCARX e INDICE y COINCIDIR – EXCELeINFO.xlsx

👇

⭐ Si te gustó este tutorial, por favor regístrate en nuestra Lista de correo y Suscríbete a nuestro canal de YouTube para que estés siempre enterado de lo nuevo que publicamos.

Leave a Comment

Your email address will not be published. Required fields are marked *

Scroll to Top