7 ejemplos con BUSCARX y Funciones de matrices dinámicas en Excel

En este video vamos a repasar dos temas importantes de fórmulas y funciones: La nueva función BUSCARX y el nuevo motor de cálculos en Excel con las funciones de matrices dinámicas o Dynamic arrayas.

Ver Video BUSCARX y funciones de MATRICES DINÁMICAS

Suscríbete al canal de EXCELeINFO en YouTube para aprender más de Excel y macros.

Función BUSCARX

A continuación algunas ventajas que traerá.

  • A diferencia de BUSCARV, aquí solo debemos elegir dos columnas, lo cual hace que la función tenga mejor desempeño.
  • Es posible encontrar el último resultado.
  • La coincidencia por defecto es EXACTA, a diferencia que con BUSCARV que debíamos definirle FALSO o VERDADERO.
  • Podemos usar comodines para búsqueda aproximada.
  • BUSCARX ya viene con la mejora de desempeño que tuvo BUSCARV en el 2018.
  • Por fin nos olvidamos de definir las columnas por número, incluso si movemos las columnas o insertamos nuevas, la búsqueda seguirá funcionando.

Ejemplo 1 – BUSCARX en lugar de BUSCARV

En este ejemplo vamos a hacer una búsqueda sencilla, tal cual lo haríamos con BUSCARV. La fórmula usada es:

=BUSCARX(G9,B9:B18,C9:C18)

Usando BUSCARX en lugar de BUSCARV

Figura 1. Usando BUSCARX en lugar de BUSCARV.

Ejemplo 2 – Buscar hacia la izquierda

Con BUSCARX es muy sencillo buscar hacia la derecha o hacia la izquierda, ya que basta con que selecciones la matriz_devuelta, ésta puede estar en cualquier dirección. Usamos la siguiente fórmula:

=BUSCARX($G9,$E$9:$E$18,B$9:B$18)

Búsqueda hacia la izquierda con BUSCARX

Figura 2. Búsqueda hacia la izquierda con BUSCARX.

Ejemplo 3 – Devolver último valor encontrado

BUSCARX nos permitirá devolver el primer valor encontrado de manera predeterminada, pero también le podemos indicar que nos devuelva el último valor encontrado en caso de que el valor buscado esté repetido en la matriz_buscada. Usamos la siguiente fórmula:

Devolver el primer o último valor encontrado con BUSCARX

Figura 3. Devolver el primer o último valor encontrado con BUSCARX.

Ejemplo 4 – BUSCARX para búsqueda horizontal

La ventaja de BUSCARX es que absorbe tanto la capacidad de búsqueda vertical de BUSCARV, como la búsqueda horizontal de BUSCARH. Usaremos al siguiente fórmula:

=BUSCARX(I9,C8:F8,C10:F10)

BUSCARX para búsqueda horizontal en Excel

Figura 4. BUSCARX para búsqueda horizontal en Excel.

Funciones de matrices dinámicas

A continuación una serie de cambios que se han hecho al motor intento de cálculos en Excel.

  1. Todas las fórmulas serán tratadas de la misma manera.
  2. Adiós a la combinación Control + Shift + Enter. Ya no debemos preocupamos por usar la anterior combinación en fórmulas matriciales.
  3. Si una fórmula devuelve un valor se reflejará en una sola celda.
  4. Si la fórmula devuelve más de una respuesta, se usará el Rango de desbordamiento para rellenar todos los resultados.

Ejemplo 5 – Funciones ORDERNAR y ORNENAR POR

Con la función ORDENAR vamos a devolver un rango ordenado con base en otro rango, sin necesidad de modificar el rango original. Usamos la siguiente fórmula:

=BUSCARX(I9,C8:F8,C10:F10)

Función ORDENAR en Excel

Figura 5. Función ORDENAR en Excel.

Con la función ORDENARPOR vamos a devolver un rango ordenado con base en otro rango, es decir, el rango devuelto será ordenado con base en otro rango que no necesariamente debe ser devuelto. Usamos la siguiente fórmula:

=ORDENARPOR(C9:C18,D9:D18)

Función ORDENARPOR en Excel

Figura 6. Función ORDENARPOR en Excel.

Ejemplo 6 – Función FILTRAR

Esta función también nos va a devolver un rango, solo que en este caso, el rango devuelto estará filtrado con base en uno o más criterios. Usamos la fórmula:

=FILTRAR(C9:C18,D9:D18>27)

Función FILTRAR en Excel

Figura 7. Función FILTRAR en Excel.

Ejemplo 7 – Función FILTRAR con Rango de desbordamiento

Recordemos que si una función devuelve más de una celda, entra en juego el Rango de desbordamiento o Spill rango que nos ayudará a mostrar todos lo valores devueltos. Usamos la siguiente formula:

=FILTRAR(B9:E18,C9:C18=”EDITH”)

Función FILTRAR en Excel y el Rango de desbordamiento

Figura 8. Función FILTRAR en Excel y el Rango de desbordamiento.

Descarga el archivo de ejemplo

BUSCARX y funciones de matrices dinámicas – EXCELeINFO.zip

 

Si te gustó este tutorial por favor regístrate en nuestra Lista de correo y Suscríbete a nuestro canal de YouTube para que estés siempre enterado de lo nuevo que publicamos.

You may also like...

Leave a Reply

Your email address will not be published.

%d bloggers like this: