Obtener los 3 mejores vendedores, con valores repetidos. BUSCARV, INDICE, COINCIDIR y K.ESIMO.MAYOR

Obtener los 3 mejores vendedores, con valores repetidos. BUSCARV, INDICE, COINCIDIR y K.ESIMO.MAYOR

Algo muy común de realizar en Microsoft Excel son las búsquedas de valores. La función más común para realizar las búsquedas es BUSCARV. Sin embargo también podemos pasar al siguiente nivel en tema de búsquedas y usar las funciones INDICE y COINCIDIR. La ventaja con estas dos últimas funciones es que podemos realizar búsquedas hacia la derecha o izquierda, lo cual estamos potenciando las búsquedas.

En este tutorial veremos cómo hacer búsquedas en una Tabla de vendedores. Nos interesa obtener el nombre de los 3 mejores vendedores en base a la cantidad de ventas. El ranking de vendedores lo obtendremos con la función K.ESIMO.MAYOR. Pero qué sucede cuando tenemos valores duplicados. Veamos.

Función BUSCARV para obtener los 3 mejores vendedores

Tenemos un rango de valores con las columnas VENTAS y NOMBRE. Deseamos obtener el dato de los 3 mejores vendedores.

Tabla de vendedores en Microsoft Excel.

Figura 1. Tabla de vendedores en Microsoft Excel.

Con la función K.ESIMO.MAYOR podemos obtener el primero, segundo y tercer número máximo de ventas, y combinada con la función BUSCARV, devolver el nombre de los vendedores. Usamos la siguiente fórmula para obtener el nombre del vendedor con más ventas. La fórmula la copiamos en las siguiente dos filas hacia abajo.

=BUSCARV(K.ESIMO.MAYOR($B$2:$B$26,E5),$B$2:$C$26,2,0)

K.ESIMO.MAYOR y BUSCARV para obtener los 3 mejores en Excel.

Figura 2. K.ESIMO.MAYOR y BUSCARV para obtener los 3 mejores en Excel.

Ver video Obtener los 3 mejores vendedores

Suscríbete al canal de EXCELeINFO en YouTube para aprender más de Excel y macros.

Qué sucede sin tengo valores repetidos

Un tema muy común es tener valores repetidos en nuestros rangos. Infortunadamente BUSCARV no cuenta con una manera de detectar valores duplicados, simplemente toma el primer valor encontrado. Para solucionar ese tema de los duplicados, sugiero tener una columna auxiliar donde sumaremos valores menores a 1 a las ventas, y la búsqueda se hará en base a esa nueva columna.

Columna auxiliar para tener valores únicos

Añadimos una columna nueva y le ingresamos una fórmula que devolverá un número menor a 1, usando la función CONTARA y FILA. En la columna auxiliar ingresamos la siguiente fórmula.

=B2+(CONTARA($B$2:$B$26)-FILA()+2)*0.001

Ahora tenemos valores únicos en la columna auxiliar y podemos obtener los 3 mejores vendedores en base a sus ventas.

Usar BUSARV para devolver valores incluso con valores repetidos.

Figura 2. Usar BUSARV para devolver valores incluso con valores repetidos.

Combinar las funciones INDICE y COINCIDIR para devolver los 3 mejores vendedores

Como vimos, la función BUSCARV es útil cuando los datos que deseamos devolver está a la derecha del valor buscamos. Para hacer búsquedas hacia la izquierda, la mejor opción es usar las funciones INDICE y COINCIDIR.

Tenemos nuestra misma tabla de vendedores, pero ahora el dato del vendedor se encuentra a la izquierda de las ventas. Así como en BUSCARV, para obtener los 3 primeros vendedores, deberemos usar una columna auxiliar para tener valores únicos y evitar el problema de los valores duplicados.

Recordemos que la función INDICE nos devuelve un valor dada la intersección de una fila y una columna. El valor de la fila lo devolveremos con la función COINCIDIR que nos ayuda a devolver la posición de un valor en una matriz. La función K.ESIMO.MAYOR nos ayudará a devolver el 1ro, 2do y 3er número más alto.

Usaremos la siguiente fórmula para devolver el primer número más alto. Para devolver el segundo, copiamos la fórmula hacia a abajo y usamos la posición 2.

=INDICE($A$2:$C$26,COINCIDIR(K.ESIMO.MAYOR($C$2:$C$26,D7),$C$2:$C$26,0),1)

Ahora podemos ver los nombres de los 3 mejores vendedores.

. Usamos INDICE, COINCIDIR y K.ESIMO.MAYOR para devolver los 3 mejores.

Figura 3. Usamos INDICE, COINCIDIR y K.ESIMO.MAYOR para devolver los 3 mejores.

Descarga el archivo de ejemplo

Descargar el ejemplo BUSCARV, INDICE, COINCIDIR y K.ESIMO.MAYOR con valores repetidos – EXCELeINFO.zip

Si te gustó este tutorial por favor regístrate en nuestra Lista de correo y Suscríbete a nuestro canal de YouTube para que estés siempre enterado de lo nuevo que publicamos.

You may also like...

Leave a Reply

Your email address will not be published. Required fields are marked *