Mostrar el Top N de valores usando la funci贸n FILTRAR en Excel

馃敟 En este video te mostrar茅 de una manera muy f谩cil de aprender, a devolver el Top N de valores de un rango, usando la funci贸n FILTRAR en Excel (matrices din谩micas).

馃弳 Y como Plus te ense帽ar茅 a usar un Control de formulario para controlar el n煤mero de filas a mostrar.

Tambi茅n te ense帽ar茅 a usar Formato condicional.

Ver video Top N en Excel usando la funci贸n FILTRAR

Suscr铆bete al canal de EXCELeINFO en YouTube para aprender m谩s de Excel y macros.

FILTRAR valores Top N

Funci贸n FILTRAR en Excel para devolver el Top N
Funci贸n FILTRAR en Excel para devolver el Top N

Para devolver el Top 5 de los valores con base en el rango, usamos la siguiente f贸rmula:

=SI(F1>=CONTARA(A:A)-1,"N煤mero inv谩lido",ORDENAR(FILTRAR(A2:C22,C2:C22>=K.ESIMO.MAYOR(C2:C22,F1)),3,-1))

Explicaci贸n

  • Primero validamos con SI si el rango devuelto por FILTRAR es mayor al rango de valores.
  • Con ORDENAR mostramos primero los valores m谩s altos.
  • FILTRAR no ayudar谩 a devolver los valores que cumplan cierta condici贸n.
  • K.ESIMO.MAYOR la usaremos para definir el n煤mero m谩ximo de filas a devolver.

Control de n煤mero (control de formulario)

Este Control nos permitir谩 definir el n煤mero m铆nimo y m谩ximo para ingresar en una celda.

  • Nos vemos a la pesta帽a Programador.
  • Elegimos Controles > Insertar > Controles de formulario > Control de n煤mero.
  • Una vez insertados, damos clic derecho y elegimos Formato de control.
  • Elegimos el valor m铆nimo, m谩ximo y lo vinculamos a una celda.
Control de formulario en Excel
Control de formulario en Excel

Colorear los N mejores valores

Usando Formato condicional, vamos a colorear las celdas con los n valores devueltos por la funci贸n FILTRAR y elegimos por el control.

  • Elegimos el rango.
  • Nos vamos a la pesta帽a Inicio > Formato condicional > Nueva regla.
  • Elegimos la opci贸n Utilice una f贸rmula que determine las celdas para aplicar formato.
  • Insertar la siguiente f贸rmula:
=C2>=K.ESIMO.MAYOR($C$2:$C$22,$F$1)

Y por 煤ltimo elegimos el formato que deseas aplicar.

Formato condiciona en Excel
Formato condiciona en Excel
Las funciones de matrices din谩micas est谩n disponibles en Excel 365 y Office 2021 en adelante.

Descarga el archivo para practicar

鉁 Mostrar el Top N de valores usando la funci贸n FILTRAR – EXCELeINFO.zip

Si te gust贸 este tutorial, por favor聽reg铆strate en nuestra Lista de correo聽y聽Suscr铆bete a nuestro canal de YouTube聽para que est茅s siempre enterado de lo nuevo que publicamos.

Certif铆cate en Excel

Tienes experiencia en Excel y quieres mejorar tus oportunidades laborales? Obt茅n la certicaci贸n Excel Expert avalada por Microsoft.

You may also like...

Leave a Reply

Your email address will not be published.

%d bloggers like this: