Efecto MouseOver en Excel para tus Dashboards

En este video tutorial veremos un Tip que puedes implementar en tus Dashboards y generar un efecto llamativo de tipo MouseOver, el cual nos ayuda a resaltar una celda al pasar el cursor sobre ella, además de cambiar los valores en un gráfico.

En este video tutorial aprenderemos:

  • Insertar gráficos.
  • Crear una función UDF con VBA y macros.
  • Uso de fórmulas y funcione. Función HIPERVINCULO.
  • Formato condicional.

Ver video Efecto MouseOver en Excel

Suscríbete al canal de EXCELeINFO en YouTube para aprender más de Excel y macros.

Resumen de ventas por sucursal

Tenemos un rango en la hoja Datos que contiene las columnas MES, SUCURSAL y VENTAS. En la hoja Cálculos usaremos la función SUMAR.SI.COJUNTO para obtener una suma de las ventas por sucursal y mes.

=SUMAR.SI.CONJUNTO(Datos!C:C,Datos!A:A,Cálculos!$B$1,Datos!B:B,Cálculos!A4)

Función SUMAR.SI.CONJUNTO para sumar valores en base a varios criterios.

Figura 1. Función SUMAR.SI.CONJUNTO para sumar valores en base a varios criterios.

En la celda B1 de la hoja Cálculos ingresamos un mes.

Gráfico de resumen

  • Seleccionamos la hoja Cálculos y luego el rango A4:B8.
  • Nos vamos a la ficha Insertar > Gráficos > Columnas agrupadas.
  • Elegimos el título del gráfico y en la barra de fórmulas ingresamos =Cálculos!$B$1 para mostrar el mes.

Desarrollando la vista

Nos vamos la hoja Vista y armamos el Dashboard.

  • En la celda B1 ingresamos VENTAS POR MES.
  • Nos vamos ficha Inicio > Estilos > Encabezado 1.
  • En las celdas B3:G4 ingresamos cada uno de los meses.
  • Nos vamos a la hoja Cálculos, cortamos el gráfico y lo pegamos en la hoja Vista.
  • En la ficha Diseño de gráfico > Estilo 11.
  • Elegimos el gráfico y elegimos el signo de más ‘+’.
  • Desmarcamos línea de cuadrícula.
  • En ejes marcamos solo Horizontal primario.
  • En la ficha Formato > Contorno de forma > Sin contorno.

Dashboard en Excel con gráfico.

Figura 2. Dashboard en Excel con gráfico.

Función UDF SeleccionarMes

Ahora mediante VBA y macros vamos a crear una función personalizada o UDF que nos ayudará a insertar cada uno de los meses en la celda B1 de la hoja cálculos.

  • Abrimos el IDE de VBA usando la combinación de teclas Alt + F11.
  • En el menú Insertar elegimos Módulo.
  • Ingresamos el siguiente código VBA.
Public Function SeleccionarMes(Celda As Range)

    Sheets("Cálculos").Range("B1").Value = Celda.Value

End Function

Función HIPERVINCULO

Nos vamos a la hoja Vista y elegimos la celda B3 que contiene el mes de enero. Usaremos la función HIPERVINCULO para crear un Vínculo que mande llamar a la función UDF SeleccionarMes. Ingresamos la siguiente formula.

=SI.ERROR(HIPERVINCULO(SeleccionarMes(B3)),”Enero”)

Usamos la misma fórmula para el resto de las celdas, cambiando la referencia a celdas y el nombre del mes.

Al ingresar la función, si pasamos el curso sobre la celda B3 que contiene Enero, vemos que cambia el cursor a una mano y cambia el gráfico.

Función HIPERVINCULO en Excel.

Figura 3. Función HIPERVINCULO en Excel.

Formato condicional para simular efecto MouseOver

Ahora lo que deseamos que cada vez que pasemos el cursos sobre alguna celda que contenga el mes, se cambie el formato de la celda.

  • Elegimos las celdas que contiene el mes y elegimos un formato.
  • Con las celdas elegidas nos vamos a la ficha Inicio > Formato condicional > Nueva regla.
  • Elegimos la opción Utilice una fórmula que determine las celdas para aplicar formato.
  • Ingresamos =B3=Cálculos!$B$1
  • Damos clic en el botón Formato y elegimos el formato al pasar el cursor sobre las celdas.

Efecto MouseOver en Excel usando Formato condicional.

Figura 4. Efecto MouseOver en Excel usando Formato condicional.

Descarga el archivo de ejemplo

Efecto MouseOver para tus Dashboards – EXCELeINFO.zip

 

Si te gustó este tutorial por favor regístrate en nuestra Lista de correo y Suscríbete a nuestro canal de YouTube para que estés siempre enterado de lo nuevo que publicamos.

You may also like...

Leave a Reply

Your email address will not be published.

%d bloggers like this: