Buscar valores hacia la izquierda en Excel. Aprende BUSCARV, COINCIDIR e INDICE

En este artículo y video veremos cómo hacer una búsqueda de valores hacia la izquierda. Comúnmente usamos la función BUSCARV para buscar valores y devolver resultados, pero la búsqueda se hace hacia la derecha. Pero ¿qué pasa cuando deseamos devolver valores que se encuentran a la izquierda del valor buscado?

Ver video buscar valores hacia la izquierda. BUSCARV, COINCIDIR e INDICE

Suscríbete al canal de EXCELeINFO en YouTube para aprender más de Excel y macros.

Uso de BUSCARV (buscar hacia la derecha)

Usamos BUSCARV cuando los valores que deseamos obtener se encuentran hacia la derecha del valor buscado. En la Figura 1 vemos que tenemos un rango donde nuestro valor buscado es el ID y los valores que deseamos devolver son Compañía, Nombre, Apellidos y Cargo.

Usaremos el ID como valor buscado.

Figura 1. Usaremos el ID como valor buscado.

Ahora bien, en base al ID vamos a devolver el valor de Nombre, usaremos la siguiente fórmula, misma que la puedes ver en Figura 2.

=BUSCARV(C8,A12:E22,3,0)

El ID 1 se buscará en el rango A12:E22 y devolveremos el valor de la tercera columna.

Figura 2. El ID 1 se buscará en el rango A12:E22 y devolveremos el valor de la tercera columna.

Uso de COINCIDIR e INDICE

La combinación de estas dos funciones nos van a permitir buscar valores y devolver resultados hacia la izquierda de donde encontramos el valor buscado.

En la Figura 3 vemos que ahora el ID se encuentra al final de nuestro rango de valores, por lo que para BUSCARV debemos mover los valores de la columna hacia la izquierda, pero como eso no siempre es viable, usaremos las funciones COINCIDIR e INDICE para buscar hacia la izquierda.

El ID ahora lo vemos a la derecha de nuestros datos.

Figura 3. El ID ahora lo vemos a la derecha de nuestros datos.

Bien, primero usaremos la función COINCIDIR para devolver la posición en la que se encuentra el ID que buscaremos. Usamos la siguiente fórmula, mis que la vemos en la Figura 4.

=COINCIDIR(C9,E14:E24,0)

Con COINCIDIR buscamos la posición del ID 44, que será la posición 5.

Figura 4. Con COINCIDIR buscamos la posición del ID 44, que será la posición 5.

Ahora con la función INDICE devolveremos un valor en base a la intersección de una fila y una columna en un rango.

Nota: El número de fila lo obtuvimos con la función COINCIDIR, que fue la fila 5. La columna de la intersección será la 2, la columna Nombre.

En la siguiente fórmula usaremos la función INDICE donde la intersección fila / columna será: fila 5, que devolvimos con la función COINCIDIR y fila 2, que será la 2, de Nombres.

Devolver valores hacia la izquierda usando las funciones COINCIDIR e INDICE.

Figura 5. Devolver valores hacia la izquierda usando las funciones COINCIDIR e INDICE.

Al final, la fórmula queda así:

=INDICE(A14:E24,COINCIDIR(C9,E14:E24),2)

Seguro te interesará

El poder de la función BUSCARV en Excel

Descargar el archivo de ejemplo

Descargar el ejemplo Buscar valores hacia la izquierda, Aprende BUSCARV, COINCIDIR e INDICE – EXCELeINFO.rar

You may also like...

RECIBE CONTENIDO EXCLUSIVO

Tips, trucos, videos para convertirte en un EXPERTO EN EXCEL y llegar al éxito. Suscríbete y recibe el mejor contenido en tu correo.