Filtrar por 2 criterios Eligiendo las columnas a devolver – ECVR – 3

Veamos un nuevo Excel, caso de la vida real.

Tenemos una tabla de datos y deseamos Filtrar la información con base en una selección de una tienda y una fecha, además de poder determinar qué columnas deseamos devolver.

Spoiler: te enseño a armar fórmulas grandes sin complicaciones.

Ver video Filtrar por 2 criterios eligiendo las columnas

Suscríbete al canal de EXCELeINFO en YouTube para aprender más de Excel y macros.

Intro

Figura 1. Uso de funciones de matrices dinámicas para filtrar por 2 condiciones – exceleinfo

En este Caso de la vida real, nos piden filtrar una Tabla de datos mediante 2 criterios. Hasta aquí todo bien, usamos la función FILTRAR y listo.

Luego se nos pide que el filtro devuelto sea de ciertas columnas a elegir. Aquí es donde se pone interesante el tema, puesto que debemos usar la función ELEGIRCOLS.

Armaremos la fórmula en 3 partes. El resultado final será:

=SI.ERROR(ORDENAR(ELEGIRCOLS(FILTRAR(Tabla1,(Tabla1[TIENDA]=$C$2)*(Tabla1[FECHA]=$C$3)),COINCIDIR($B$6:$H$6,Tabla1[#Encabezados],0)),1),"Revisa")

Función FILTRAR

Aquí usamos la función FILTRAR para devolver los datos con base en 2 criterios.

Usamos la siguiente fórmula:

=FILTRAR(Tabla1,(Tabla1[TIENDA]=$C$2)*(Tabla1[FECHA]=$C$3))

Función ELEGIRCOLS

Con base en los devuelto por la fórmula anterior, ahora toca decirle a Excel cuáles columnas deseamos devolver. Para eso usamos la función ELEGIRCOLS.

=ELEGIRCOLS(B12#,COINCIDIR($B$6:$H$6,Tabla1[#Encabezados],0))

Función ORDENAR

Y para finalizar ordenamos los datos devueltos por ELEGIRCOLS.

=ORDENAR(B17#,1)

Descarga el archivo para practicar

Filtrar por tienda y fecha, eligiendo las columnas – ECVR.zip

👇

⭐ Si te gustó este tutorial, por favor regístrate en nuestra Lista de correo y Suscríbete a nuestro canal de YouTube para que estés siempre enterado de lo nuevo que publicamos.

Leave a Comment

Your email address will not be published. Required fields are marked *

Scroll to Top