Formulario de consulta en Excel con BUSCARV

He creado un formulario que comparto con ustedes. Sin macros.

El archivo cuenta con 2 hojas: una con el formulario de consulta y otra donde  se encuentra la base de datos. La base de datos contiene una lista de nombres de personas. Cada registro cuenta con un ID como identificador único.

Hacer una consulta por ID o por nombre

Para realizar la consulta a la base de datos (segunda hoja) tendremos una lista de validación donde desplegarán ID y NOMBRE, que serán las 2 maneras mediante las cuales podremos traer los datos correspondientes.

Como sabemos, la función BUSCARV tiene como parámetros el valor buscado, la matriz donde se buscará el valor, la columna donde está el valor a traer y si queremos una búsqueda exacta y aproximada.

En el archivo usaremos la función BUSCARV, pero los parámetros de matriz y el indicador de columna serán condicionados con la función SI, dependiendo de si elegimos la búsqueda por ID o por NOMBRE.

Ver video Búsqueda por ID o Nombre usando BUSCARV en Excel.

SUSCRÍBETE a nuestro canal para aprender más de Excel.

 SUSCRÍBETE  nuestro canal de YouTube!

Condicionar matriz de búsqueda

Por ejemplo, para condicionar la matriz de búsqueda, haremos la función SI como se muestra en las letras negritas:

=SI.ERROR(BUSCARV(D11,SI(D9=”ID”,Base!$A$1:$K$69,SI(D9=”NOMBRE”,Base!$B$1:$K$69)),SI(D9=”ID”,3,SI(D9=”NOMBRE”,2)),0),”-“)

Condicionar el indicador de columnas

Y para condicionar el indicador de columnas, la función SI se hará como lo muestra las letras negritas:

=SI.ERROR(BUSCARV(D11,SI(D9=”ID”,Base!$A$1:$K$69,SI(D9=”NOMBRE”,Base!$B$1:$K$69)),SI(D9=”ID”,3,SI(D9=”NOMBRE”,2)),0),”-“)

GIF del formulario en acción

Formulario con BUSCARV

:: Descarga el ejemplo EXCELeINFO – formulario de consulta con BUSCARV.xlsm

You may also like...

7 Responses

  1. ¿Funciona al seleccionar buscar por nombre?

  2. José Páucar says:

    Sí funciona, ya lo he probado.

  3. Maquinangel says:

    Muchas gracias, me sirvio de mucho.

  4. tudineroweb says:

    interesante lo descargare

  1. January 22, 2013

    […] Formulario de consulta en Excel con BUSCARV […]

  2. January 26, 2013

    […] un artículo anterior titulado Formulario de consulta en Excel con BUSCARV compartía un libro de Excel que tenía como objetivo utilizar la función BUSCARV para consulta de […]

  3. April 7, 2013

    […] Existen complementos que crean funciones personalizadas, menús contextuales, pestañas en Ribbon, formularios y […]

Leave a Reply

Your email address will not be published. Required fields are marked *