Usar BUSCARV y BUSCARX distinguiendo mayúsculas y minúsculas en Excel

En este video te mostraré con qué funciones debes combinar BUSCARV y BUSCARX para realizar búsquedas distinguiendo mayúsculas de minúsculas en Excel.

Usaremos las funciones IGUAL y ELEGIR, combinadas con las anteriores.

Aunque se puede hacer en Office 2019 hacia atrás, se recomiendo tener Office 2021 u Office 365.

Ver video BUSCARV y BUSCARX distinguiendo mayúsculas y minúsculas

Suscríbete al canal de EXCELeINFO en YouTube para aprender más de Excel y macros.

Tenemos el siguiente rango, donde tenemos valores que distinguiremos mayúsculas y minúsculas.

Rango de celdas donde usaremos BUSCARV y BUSCARX

Figura 1. Rango de celdas donde usaremos BUSCARV y BUSCARX.

Función IGUAL

Esta función nos permite comparar dos textos para saber sin son idénticos, distinguiendo mayúsculas de minúsculas.

=IGUAL(“Sergio”,”sergio”)

La función devolverá FALSO.

Función ELEGIR

Con esta función devolveremos una matriz bidimensional que será usada como parámetro en BUSCARV.

=ELEGIR({1,2},IGUAL(“sergio”,A6:A10),C6:C10)

Esta función devolverá la siguiente matriz

Con la función ELEGIR devolveremos esta matriz en Excel

Figura 2. Con la función ELEGIR devolveremos esta matriz en Excel.

Función BUSCARV distinguiendo mayúsculas y minúsculas

Usaremos la siguiente fórmula donde usaremos BUSCARV y anidaremos las funciones ELEGIR e IGUAL.

=BUSCARV(VERDADERO,ELEGIR({1,2},IGUAL(F6,A6:A10),B6:B10),2,0)

BUSCARV case sensitive en Excel

Figura 3. BUSCARV case sensitive en Excel.

Función BUSCARX distinguiendo mayúsculas y minúsculas

Usaremos la siguiente fórmula donde usaremos BUSCARV y anidaremos la función IGUAL.

=BUSCARX(VERDADERO,IGUAL(I6,A6:A10),C6:C10,”Texto no encontrado”)

BUSCARX case sensitive Excel

Figura 4. BUSCARX case sensitive Excel.

Descargar el archivo de Ejemplo

BUSCARV y BUSCARV reconociendo mayúsculas y minúsculas – EXCELeINFO.zip

Si te gustó este tutorial, por favor regístrate en nuestra Lista de correo y Suscríbete a nuestro canal de YouTube para que estés siempre enterado de lo nuevo que publicamos.

You may also like...

Leave a Reply

Your email address will not be published.

%d bloggers like this: