Simular BUSCARV con valores repetidos en Excel

Como hemos comentado en posts anteriores, la función BUSCARV es de las más socorridas para hacer búsquedas de datos en tablas. La complicación llega cuando tenemos en nuestra tabla valores repetidos.

En la siguiente tabla, BUSCARV nos traerá el valor de 67 si queremos traer las ventas de ‘Sergio’.

image

Ahora bien, en nuestra tabla tenemos otro valor para ‘Sergio’ que está en la fila 9, que son 9 ventas. Para obtener tal resultado utilizamos una fórmula matrical propuesta por Chip Pearson.

Suponiendo que ‘nombres’ es nuestra tabla y que deseamos obtener el valor dependiendo de la posición que deseemos.

={INDICE(nombres,K.ESIMO.MENOR(SI(DESREF(nombres,0,0,FILAS(nombres),1)=B14,FILA(DESREF(nombres,0,0,FILAS(nombres),1))-FILA(DESREF(nombres,0,0,1,1))+1,FILA(DESREF(nombres,FILAS(nombres)-1,0,1,1))+1),B15),2)}

image

Nota: al copiar se deben eliminar los las llaves de inicio y fin, ya que se ingresarán automáticamente al presionar Ctlr + Shift + Enter, ya que es fórmula matrical.

En caso de que ingresemos una posición inexistente, el resultado que nos arrojará será #¡REF!

Para eso vamos a combinar la fórmula con la función SI.ERROR para obtener un mensaje personalizado en caso de error. La fórmula quedaría:

{=SI.ERROR(INDICE(nombres,K.ESIMO.MENOR(SI(DESREF(nombres,0,0,FILAS(nombres),1)=B14,FILA(DESREF(nombres,0,0,FILAS(nombres),1))-FILA(DESREF(nombres,0,0,1,1))+1,FILA(DESREF(nombres,FILAS(nombres)-1,0,1,1))+1),B15),2),"No hay datos")}

You may also like...

4 Responses

  1. Fer.Cip says:

    Se me ocurre algo mucho mas simple en B15

    {=SUMA((B2:B12)*( A2:A9=B14))}

    Es una fórmula matricial, ingresar con Ctlr + Shift + Enter
    Está sumando el rango B2 a B12 si el rango A2:A9 coincide con el valor de B14
    Si lo que ingresamos no coincide, simplemente no suma, no da error.
    Salutes,

  2. Brittany says:

    I discovered your Simular BUSCARV con valores repetidos en Excel – EXCELeINFO page and noticed you could have a lot more traffic. I have found that the key to running a popular website is making sure the visitors you are getting are interested in your niche. There is a company that you can get traffic from and they let you try the service for free. I managed to get over 300 targeted visitors to day to my website. Check it out here: http://1h.ae/el0

  1. April 13, 2013

    […] Simular BUSCARV con valores repetidos en Excel. […]

  2. August 8, 2013

    […] Simular BUSCARV con valores repetidos en Excel […]

Leave a Reply

Your email address will not be published. Required fields are marked *

%d bloggers like this: