Uso de K.ESIMO.MAYOR, COINCIDIR, INDICE en una misma fórmula de Excel

Compartir:

Twittear este post

 Compartir en Facebook

En varias ocasiones nos topamos con fórmulas grandes con funciones anidadas y que a simple vista son de difícil lectura. El siguiente ejemplo nos deja más claro cómo realizar este tipo de fórmulas paso a paso. El ejemplo nos muestra cómo obtener de una lista de nombres con sus respectivas ventas, quién es el 1ro, 2do y 3er lugar dependiendo de las ventas.

Primeramente tenemos nuestra base de datos con sólo dos columnas: la columna Nombre y la columna Ventas.

1.- El primer paso es obtener cuál es el número mayor de ventas. Esto lo obtenemos con la función K.ESIMO.MAYOR. Cabe destacar que esta función nos da el número k.esimo de una lista, de mayor a menor:

[B10]=K.ESIMO.MAYOR(B2:B8,1)

2.- Ahora que obtenemos el valor del número k, que en esta ocasión fue el número mayor, el 1, nos disponemos a obtener la posición de dicho número en la fila, con la función COINCIDIR:

[B11]=COINCIDIR(B10,B2:B8,0)

3.- Cuando sabemos la posición en la que está el número mayor, el 1ro, nos disponemos a obtener el nombre de la persona que tuvo ese número de ventas, con la función INDICE. Dicha función nos da el valor correspondiente de acuerdo a la intersección de fila columa que definimos en los parámetros.

[B12]=INDICE(A2:B8,B11,1)

4.- Hasta este momento ya obtuvimos el valor de la persona que tuvo más ventas, pero utilizando 3 funciones, una en cada celda. Ahora necesitamos unirlas todas. Si nos damos cuenta, en la celda [B11] hacemos referencia a la celda [B10], entonces la fórmula que está en [B10] la copiamos y la pegamos íntegramente donde dice ‘B10’ en la fórmula de [B11], y así hacemos lo mismo en la celda [B12]. Dándonos como resultado la siguiente fórmula:

=INDICE(A2:B8,COINCIDIR(K.ESIMO.MAYOR(B2:B8,1),B2:B8,0),1)

Resumen:

Con K.ESIMO.MAYOR obtuvimos el número mayor de ventas que es 120, después con COINCIDIR sacamos la posición de ese valor en la tabla, que fue la posición 3. La intersección que nos dan las dos funciones pasadas son fila 3 y la columna donde está el valor que queremos es la columna 1, por lo tanto, el nombre que nos arroja es Toño.

Imagen del ejemplo:

image

:: Descarga el ejemplo

You may also like...

7 Responses

  1. Hugo says:

    Me encuentro en un dilema. Tengo dos resultados iguales en la columna de ventas y la fórmula me da el nombre del primer vendedor mientras quiero el nombre del segundo vendedor. ¿Cómo se puede lograr esto?

  2. kary says:

    osh tengo el mismo problema que el amigo de aqui abajo.. tengo numeros repetidos.. any help??? 🙁 ya no se que hacer…

  3. El mismo problema de los repetidos

  4. sergioacamposh says:

    Les aconsejo revisar la siguiente página de CPearson y revisar el tema de Ascending Player Rankings. El ejemplo enumera los x mejores en una lista, tomando en cuenta los que están repetidos. http://www.cpearson.com/Excel/rank.aspx

  5. Siguiendo el hilo del tema, he publicado un post referente al BUSCARV cuando tenemos valores repetidos: http://exceleinfo.wordpress.com/2012/05/17/simular-buscarv-con-valores-repetidos-en-excel/

  6. Gustavo says:

    muchas gracias !!!

Leave a Reply

Your email address will not be published. Required fields are marked *