Factura en Excel Parte 1 – Plantilla, Fórmulas y listas de validación de clientes y productos

Factura en Excel Parte 1 - Plantilla, Fórmulas y listas de validación de clientes y productos

En esta primera parte del Proyecto Factura en Excel descargaremos una plantilla de una Factura sencilla y la formularemos para traer los datos del Cliente a facturar en base a su nombre elegido en una lista de validación, así como devolver la información de las descripción de los productos en base a otra lista de validación. Tendremos la hoja Factura, Detalle de facturas, tabla de Clientes y tabla de Productos.

En la segunda parte de este tutorial usaremos macros VBA para guardar la información de cada factura en una hoja aparte e incrementar el número de factura automáticamente.

Descargando la plantilla

Excel nos provee de miles de plantillas en línea que podemos descargar y modificarlas a nuestro gusto. Para este proyecto de Factura descargaremos una Factura sencilla las cual modificaremos añadiéndole algunas fórmulas y validaciones de datos.

  • No vamos a la pestaña Archivo > Nuevo.
  • En la caja de texto Buscar plantillas en línea escribimos Factura simple.
  • Seleccionamos la plantilla Factura simple que calcula el total.

Descargamos una plantilla de Factura simple en línea.

Figura 1. Descargamos una plantilla de Factura simple en línea.

Ver Video Factura en Excel Parte 1

Suscríbete al canal de EXCELeINFO en YouTube para aprender más de Excel y macros.

Añadiendo columnas extras

La plantilla sólo cuenta con las columnas DESCRIPCIÓN e IMPORTE. Para que sea una factura algo más completa, la modificaremos para tener las columnas CÓDIGO, DESCRIPCIÓN, CANTIDAD e IMPORTE.

Modificamos la plantilla de la factura que descargamos en línea.

Figura 2. Modificamos la plantilla de la factura que descargamos en línea.

Agregar hojas nuevas

Agregaremos las siguientes 3 hojas al archivo para tener una factura más dinámica:

  • Detalle de facturas: En la parte 2 de este tutorial guardaremos en esta hoja el detalle de cada factura.
  • Clientes: En esta hoja tendremos una tabla de Clientes.
  • Productos: En esta hoja tendremos una tabla de Productos.

Hoja Clientes

En la hoja Clientes tendremos una tabla ficticia con los datos de posibles clientes a los que podemos generarles una factura, tendremos los datos de:

  • Nombre.
  • Nombre de la empresa.
  • Dirección.
  • Ciudad, estado y CP.
  • Teléfono.

Convertiremos este rango en Tabla para posteriormente usar el nombre de los Clientes en una Lista de validación.

  • Seleccionamos el rango.
  • Presionamos [Control] + [T].
  • Marcamos la opción La tabla tiene encabezados.
  • En la pestaña Herramientas de tabla le ponemos el nombre tblClientes a la tabla.

Tenemos una tabla de Clientes para nuestra factura.

Figura 3. Tenemos una tabla de Clientes para nuestra factura.

Hoja Productos

En la hoja Productos estarán los productos que podremos facturar, de los cuales tendremos la siguiente información:

  • Código.
  • Descripción.
  • Precio unitario.

Siguiendo los mismos pasos que para la hoja Clientes, convertimos el dato de los productos en tabla y a la tabla le pondremos el nombre tblProductos.

Tenemos una tabla de productos para nuestra factura.

Figura 4. Tenemos una tabla de productos para nuestra factura.

Devolver automáticamente los datos del cliente a facturar

Ahora que tenemos una tabla de Clientes, en la carátula de la Factura, en la sección Facturar a, insertaremos una lista de validación para mostrar el nombre de los clientes y en la parte inferior se muestren los datos del cliente elegido.

  • Seleccionamos la celda B7.
  • Nos dirigismos a la pestaña Datos > Validación de datos.
  • Elegimos Permitir Lista y en origen ingresamos la fórmula =INDIRECTO(“tblClientes[Nombre]”).

Obtendremos una Lista de validación con los nombres de los clientes.

Lista de validación para mostrar el nombre de los clientes.

Figura 5. Lista de validación para mostrar el nombre de los clientes.

Ahora haremos uso de la función BUSCARV para devolver los datos correspondientes al cliente elegido en la lista de validación. Ingresamos la siguiente fórmula en la celda B8 para devolver el nombre de la empresa:

=SI.ERROR(BUSCARV(B7,tblClientes[#Todo],2,0),”-“)

Para los valores posteriores sólo reemplazaremos el número 2 por el número 3 hasta llegar al número 5 que es la columna donde está el valor del teléfono.

Devolver automáticamente la descripción de los productos

Así como en los clientes, para enlistar los códigos de los productos lo haremos mediante una lista de validación.

  • Seleccionamos el rango B13:B23.
  • Nos dirigismos a la pestaña Datos > Validación de datos.
  • Elegimos Permitir Lista y en origen ingresamos la fórmula =INDIRECTO(“tblProductos[CODIGO]”).

Ahora que tenemos la lista de Códigos, en la columna C que la columna DESCRIPCIÓN usaremos la función BUSCARV para devolver la descripción de cada producto. Usaremos la formula:

=SI.ERROR(BUSCARV([@CÓDIGO],tblProductos[#Todo],2,0),””)

Con la función BUSCARV devolvemos la descripción del producto.

Figura 6. Con la función BUSCARV devolvemos la descripción del producto.

Calcular el subtotal por producto

Ya ingresamos el código, se devolvió la descripción e ingresamos la cantidad. Ahora nos falta calcular el IMPORTE de cada línea facturada. En la columna IMPORTE ingresamos una fórmula que multiplicará la cantidad de productos por el precio unitario del producto elegido. Recordemos que el precio unitario lo tenemos en la tabla Productos. Usamos la siguiente fórmula:

=SI.ERROR([@CANTIDAD]*BUSCARV([@CÓDIGO],tblProductos[#Todo],3,0),””)

Con la función BUSARV devolvemos el precio unitario de cada producto y lo multiplicamos por la cantidad.

Figura 7. Con la función BUSARV devolvemos el precio unitario de cada producto y lo multiplicamos por la cantidad.

Descarga el archivo de ejemplo

Descargar el ejemplo Factura simple que calcula el total – Parte 1 – EXCELeINFO.xlsx

Si te gustó este tutorial por favor regístrate en nuestra Lista de correo y Suscríbete a nuestro canal de YouTube para que estés siempre enterado de lo nuevo que publicamos.

 

FACTURA EN EXCEL PARTE 2

You may also like...

RECIBE CONTENIDO EXCLUSIVO

Tips, trucos, videos para convertirte en un EXPERTO EN EXCEL y llegar al éxito. Suscríbete y recibe el mejor contenido en tu correo.