Uso de BUSCARV con coincidencia aproximada en Excel

Planteamiento: Tengo una lista de vendedores con sus respectivas ventas y requiero una Tabla dinámica donde pueda ver por bloque de ventas, la cantidad de vendedores. Por ejemplo:

  • Cuántos vendedores tienen ventas menos de 500.
  • Cuantos vendedores tienen ventas entre 500 y 1,000.
  • Cuantos vendedores tienen ventas entre 1,000 y 2,000.

Como vemos, en la anterior premisa nos piden hacer una Tabla dinámica donde hagamos grupos de vendedores categorizados por rango de venta. Para armar los grupos tomaremos en cuenta la cantidad de ventas de cada vendedor y ese dato lo usaremos como valor buscado en la función BUSCAR usando una coincidencia aproximada.

En la primera columna tenemos el código del vendedor y en la segunda la cantidad ventas.

Figura 1. En la primera columna tenemos el código del vendedor y en la segunda la cantidad ventas.

Ver el video Ejemplo práctico usando BUSCARV con coincidencia aproximada en Excel

Suscríbete a EXCELeINFO en YouTube

SUSCRÍBETE a nuestro canal para aprender más de Excel.

BUSCARV con coincidencia aproximada

En la mayoría de las ocasiones he usado BUSCARV con coincidencia exacta para devolver un resultado de una tabla en base a otro valor. En esta ocasión usaremos una coincidencia aproximada, ya que para obtener el dato que se requiere se tendría que armar una fórmula con varias funciones SI anidadas para definir el límite inferior y superior y ver a qué grupo pertenece.

Lo primero que haremos es una tabla donde definiremos los límites inferiores y superiores, así el nombre de cada grupo a definir.

Definimos los límites inferiores y superiores.

Figura 2. Definimos los límites inferiores y superiores.

Entendiendo la coincidencia aproximada

La coincidencia aproximada implica buscar una coincidencia en en valor próximo hacia abajo, es decir, en la tabla de la Figura 2 primero usamos el límite inferior cero y el límite superior 500. Con lo anterior quiero decir que cualquier número  menor a 500 entrará en el grupo de 0 a 500.

A considerar: La coincidencia aproximada NO busca el valor más cercano hacia arriba, sino hacia abajo.

Para saber a qué grupo pertenece cada vendedor con respecto a su cantidad de ventas, usamos la fórmula:

=BUSCARV(B2,$E$4:$G$14,3,VERDADERO)

Uso de BUSCARV con coincidencia aproximada

Figura 3. Uso de BUSCARV con coincidencia aproximada.

Armando la Tabla dinámica

Elegimos nuestro rango con el dato de los vendedores. Elegimos la pestaña Insertar, elegimos Tabla dinámica. Seleccionamos que se inserte en una nueva hoja.

Tabla dinámica en Excel

Figura 4. Tabla dinámica en Excel.

Nuestra Tabla tiene los campos VENDEDOR, VENTAS y TIPO. En nuestro esquema de Tabla dinámica arrastramos el campo TIPO hacia la sección de Filas y de nuevo el mismo campo TIPO hacia la sección Valores.

Armando la Tabla dinámica

Figura 5. Armando la Tabla dinámica.

Descarga el ejemplo

Descarga el archivo de ejemplo para aplicar la fórmula a tus propios proyectos.

Descargar el ejemplo BUSCARV con 1.rar

You may also like...