Buscar en base a dos columnas y listas dependientes en Excel INDICE, COINCIDIR y BUSCARV

Buscar en base a dos columnas y listas dependientes en Excel INDICE, COINCIDIR y BUSCARV

Regularmente las búsquedas de valores son en base a una columna y usando la función BUSCARV, o en casos más avanzados, ÍNDICE y COINCIDIR. Pero qué sucede cuando necesitamos hacer una búsqueda en base a dos columnas. Aquí es donde tenemos que usar una fórmula matricial para lograrlo. Además veremos cómo tener lista de validación dependientes.

Buscar valores en base a dos columnas

En nuestro ejemplo tenemos un rango de Equipos celulares y la búsqueda que necesitamos realizar es en base a las columnas MARCAR y MODELO, y devolver el valor del código correspondiente.

Buscamos devolver el código en base a la marca y modelo.

Figura 1. Buscamos devolver el código en base a la marca y modelo.

En la celda B2 ingresamos el valor de la marca y  en la celda B3 el modelo, y usaremos la siguiente fórmula matricial para devolver el código en base los datos elegidos.

=INDICE(G1:G15,COINCIDIR(B2&B3,E1:E15&F1:F15,0))

Nota: La fórmula anterior es matricial, por lo que deberás ingresar la combinación de teclas [Control] + [Shift] + [Enter].

Fórmula matricial para buscar valores en base a dos columnas.

Figura 2. Fórmula matricial para buscar valores en base a dos columnas.

Ver video Buscar en base a dos columnas

Suscríbete al canal de EXCELeINFO en YouTube para aprender más de Excel y macros.

Usar BUSCARV para buscar en base a dos columnas

Si no deseas utilizar la anterior fórmula matricial, siempre está la función BUSCARV para rescatarnos. Si deseas usar BUSCARV deberás insertar una columna adicional en el rango y concatenar la marca y modelo. La función BUSCAR tomará como valor buscado la unión de la marca y modelo de las celdas B2 y B3 y la matriz de búsqueda deberá comenzar en la nueva columna.

Usamos la siguiente fórmula:

=BUSCARV(B2&B3,G1:H15,2,0)

Creamos una columna adicional para concatenar las columnas de marca y modelo.

Figura 3. Creamos una columna adicional para concatenar las columnas de marca y modelo.

Listas dependientes con Validación de datos

En nuestro de Validación de datos ya hemos tocado el tema de las listas dependientes, por lo que tomaremos las fórmulas utilizadas en ese tutorial para aplicarlas en este ejemplo.

Aplicaremos Validación de datos a las celdas B2 de la marca y B3 del modelo. Al elegir una marca, se desplegarán los modelos de dicha marca. El primer paso será crear una Tabla dinámica para tener una lista única de las marcas y esa lista se usará en la Validación de datos.

  • Convertimos el rango a Tabla usando la combinación [Control] + [T].
  • Nos vamos a la pestaña Insertar > Tabla dinámica.
  • Insertamos la Tabla dinámica en la celda J1.
  • Movemos el campo MARCA a la sección Filas.

Ahora que tenemos la lista de valores únicos de marcas, toca definir las fórmulas que usaremos en las celdas de marca y modelo.

  • Elegimos la celda B2.
  • Nos vamos a la pestaña Datos > Validación de datos.
  • En Permitir elegimos Lista.
  • Ingresamos la fórmula: =DESREF(J1,1,0,CONTARA(J:J)-1)

Usamos la función DESREF para devolver los valores de las marcas.

Figura 4. Usamos la función DESREF para devolver los valores de las marcas.

Hacemos lo mismo para la celda B3 que devolverá los modelos dependiendo la marca elegida. Y usamos la siguiente fórmula:

=DESREF(E1,COINCIDIR(B2,E:E,0)-1,1,CONTAR.SI(E:E,B2),1)

Una vez que tengamos las fórmulas definidas en Validación de datos podemos probar eligiendo una marca y veremos cómo se despliegan los modelos asociados a esa marca.

Dependiendo la marca, se desplegarán los modelos correspondientes.

Figura 5. Dependiendo la marca, se desplegarán los modelos correspondientes.

Descargar el archivo de ejemplo

Descargar el ejemplo Buscar en base a dos columnas y listas dependientes INDICE, COINCIDIR y BUSCARV – EXCELeINFO.zip

 

Si te gustó este tutorial por favor regístrate en nuestra Lista de correo y Suscríbete a nuestro canal de YouTube para que estés siempre enterado de lo nuevo que publicamos.

You may also like...

RECIBE CONTENIDO EXCLUSIVO

Tips, trucos, videos para convertirte en un EXPERTO EN EXCEL y llegar al éxito. Suscríbete y recibe el mejor contenido en tu correo.